Er zijn kwetsbaarheden verholpen in Ruby. De kwetsbaarheden stellen een kwaadwillende in staat aanvallen uit te voeren die leiden tot de volgende categorieën schade:

Omzeilen van beveiligingsmaatregel
(Remote) code execution (Gebruikersrechten)
Toegang tot systeemgegevens